In a message dated 4/2/2006 10:51:12 AM Eastern Standard Time, ih8mj@fjf.gnu.de writes:
<< BTW, native speakers, with formulation is better, "integer with/of N bits"? >>
The description "Integer of N bits" is better. For the declaration, both IntegerOfBits(n) and IntegerWithBits(n) seem awkward. I would prefer the shorter IntegerOf (n) or possibly IntegerOfSize (n).
Frank Rubin
Contestcen@aol.com wrote:
<< BTW, native speakers, with formulation is better, "integer with/of N bits"? >>
The description "Integer of N bits" is better. For the declaration, both IntegerOfBits(n) and IntegerWithBits(n) seem awkward. I would prefer the shorter IntegerOf (n) or possibly IntegerOfSize (n).
I feel we should use consistent terminology. The SizeOf function returns a number of bytes, the BitSizeOf function returns a number of bits. Using just "size" when the requested parameter is a number of bits, introduces sloppy terminology, which - in general - is a source of programming errors. With IntegerOf(n), one can (implicitely) read IntegerOf(bits), so I think that is OK.
Regards,
Adriaan van Os
Adriaan van Os wrote:
Contestcen@aol.com wrote:
<< BTW, native speakers, with formulation is better, "integer with/of N bits"? >>
The description "Integer of N bits" is better. For the declaration, both IntegerOfBits(n) and IntegerWithBits(n) seem awkward. I would prefer the shorter IntegerOf (n) or possibly IntegerOfSize (n).
I feel we should use consistent terminology. The SizeOf function returns a number of bytes, the BitSizeOf function returns a number of bits. Using just "size" when the requested parameter is a number of bits, introduces sloppy terminology, which - in general - is a source of programming errors. With IntegerOf(n), one can (implicitely) read IntegerOf(bits), so I think that is OK.
I agree that "size" would be confusing (which also applies to the current attribute, of course). I also think awkwardness doesn't matter so much as clarity, as it should be used rarely, so in case of doubt, I'd tend to a longer name, even IntegerOfBitSize.
But still the question stands (as I wrote before) if we'll need it at all ...
Frank