<< I feel we should use consistent terminology. The SizeOf function returns a number of bytes, the BitSizeOf function returns a number of bits. Using just "size" when the requested parameter is a number of bits, introduces sloppy terminology, which - in general - is a source of programming errors. With IntegerOf(n), one can (implicitely) read IntegerOf(bits), so I think that is OK.
Regards,
Adriaan van Os >>
If you want to be grammatical and consistent, then consider IntegerOfBitSize(n). For my taste, however, this is just too long.
Frank Rubin